YSoft SAFEQ Cloud - Potential issues with a PC client after auto update – Incident details

All systems operational

Potential issues with a PC client after auto update

Resolved
Operational
Started 4 months agoLasted about 17 hours

Affected

EU Data Center

Degraded performance from 1:00 PM to 1:48 PM, Operational from 1:48 PM to 6:22 AM

Printing

Degraded performance from 1:00 PM to 1:48 PM, Operational from 1:48 PM to 6:22 AM

DE Data Center

Degraded performance from 1:00 PM to 1:48 PM, Operational from 1:48 PM to 6:22 AM

Printing

Degraded performance from 1:00 PM to 1:48 PM, Operational from 1:48 PM to 6:22 AM

EU-Central Data Center

Degraded performance from 1:00 PM to 1:48 PM, Operational from 1:48 PM to 6:22 AM

Printing

Degraded performance from 1:00 PM to 1:48 PM, Operational from 1:48 PM to 6:22 AM

Updates
  • Postmortem
    Postmortem

    On February 24, 2026, we identified an issue in the SAFEQ Cloud Windows PC Client auto-update where a change in the installer’s update logic could leave the previous client version still running while required driver files were removed. As a result, users could usually continue printing on already-installed queues, but printing could fail when changes were applied—for example when adding new printers/queues, when queues were recreated, or when “delete printers on logout” was used.

     

    We immediately shipped a corrected update and confirmed stability through continued monitoring  Most affected clients recovered automatically as the fix propagated; where immediate recovery was needed, refreshing printers/queues (or restarting the workstation / client) restored functionality.

     

    To reduce recurrence risk, we are strengthening safeguards for critical update flows, including enforced automated regression checks, more evidence-based release gates, and improved monitoring/alerting for update failures. We have also updated the partner and customer SLA report to include visibility into PC Client auto-update success rates.

  • Resolved
    Resolved

    All our metrics past 12 hours show the pc client update working properly.

  • Monitoring
    Monitoring

    We have implemented a fix and are currently monitoring the result. The fix shall apply automatically with next printer / queues refresh or upon user clicking "synchronize printers" from the pc client menu. alternatively disabling the auto update or restart of affected PC also solves the situation.

  • Resolved
    Resolved
    This incident has been resolved.
  • Investigating
    Investigating

    We have received reports that a limited number of customers are encountering error messages related to the recent auto-update and issues with newly added printers not appearing. Most customers updated successfully without impact. Our team is actively investigating and working on a resolution.