EU Data Center - Messaging issues

Incident Report for YSoft SAFEQ Cloud

Resolved

This incident has been resolved.
Posted Mar 27, 2025 - 11:08 CET

Update

We are continuing to work on a fix for this issue.
Posted Mar 27, 2025 - 11:07 CET

Identified

Service is recovering and operations are returning to normal. We’re monitoring closely to ensure full stability.
Posted Mar 27, 2025 - 10:36 CET

Investigating

We are investigating alerts that we have received, and SMTP and Mobile Print service may be degraded.

We will keep you informed as soon as we know more.

Updates will follow on this channel.
Posted Mar 27, 2025 - 09:36 CET
This incident affected: EU data center.