Potentially degraded performance
Incident Report for YSoft SAFEQ Cloud
Resolved
We are pleased to inform that our service has now been resumed at normal level.
Posted Jun 07, 2023 - 19:16 CEST
Investigating
We are working on improving the service availability. We apologize for any inconveniences
Posted Jun 07, 2023 - 14:31 CEST
This incident affected: EU data center.