We're Investigating: Possible Issue with London Data Center

Incident Report for YSoft SAFEQ Cloud

Resolved

This incident has been resolved.
Posted Mar 24, 2025 - 18:04 CET

Investigating

We have identified an issue with accessing the London Data Center via standard port 443.

We are working to resolve this as quickly as possible.
Posted Mar 24, 2025 - 17:44 CET
This incident affected: UK GovCloud data center.